Technologies

Le choix des technologies peut s’avérer difficile et une analyse sérieuse à du être effectuée pour une utilisation complète basé sur la popularité et la facilité de prise en main.

Framework et librairies :

Requirements

  • APACHE / IIS / NGINX
    • Le serveur doit avoir la réécriture d'url activé pour fonctionné (rewrite_mod).
  • PHP 5.2 et plus
    • GD activé
    • SPL
    • SimpleXML et XML READER
    • PDO
  • MYSQL

Note: Pour utiliser Magix CMS avec PHP 5.3

error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED 

Note: Pour utiliser Magix CMS avec PHP 5.4

error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT